Adobe Creative SDK

Follow

The required SystemConfiguration.framework is missing, causing "Undefined Symbols" errors.

If you are getting Undefined Symbols errors similar to the following, it usually means the required SystemConfiguration.framework is missing.
 
Undefined symbols for architecture x86_64:
 "_SCNetworkReachabilityCreateWithAddress", referenced from:
     +[AdobeNetworkReachability reachabilityWithAddress:] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
 "_SCNetworkReachabilityCreateWithName", referenced from:
     +[AdobeNetworkReachability reachabilityWithHostName:] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
 "_SCNetworkReachabilityGetFlags", referenced from:
     -[AdobeNetworkReachability connectionRequired] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
     -[AdobeNetworkReachability currentReachabilityStatus] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
 "_SCNetworkReachabilitySetCallback", referenced from:
     -[AdobeNetworkReachability startNotifier] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
     -[AdobeNetworkReachability stopNotifier] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
 "_SCNetworkReachabilitySetDispatchQueue", referenced from:
     -[AdobeNetworkReachability startNotifier] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
     -[AdobeNetworkReachability stopNotifier] in AdobeCreativeSDKFoundation(AdobeNetworkReachability.o)
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)

You can resolve the issue by adding SystemConfiguration.framework manually.

Was this article helpful?
1 out of 1 found this helpful

Comments

Powered by Zendesk